There was error splitting the bbox

Alistiar Brown's Avatar

Alistiar Brown

15 Aug, 2016 08:04 PM

Hello,

I am running the following command from the command line :-

C:\Program Files (x86)\Arc2Earth LLC\Arc2Earth>A2EExporter.exe -type tile -mxd "
Z:\\NWN_Data\NWN_Data\NWN_Data\NWN_Data.mxd" -start 17 -end 17 -
fullExtent true -cache "Z:\Tiles" -cf zxy -transparent true -an
tialias false -adaptive true -format png8 -cutters 16
Initializing exporter (tile2)...
Starting multiple cutters 16

but I get this error

there was error splitting the bbox.

----------------------------

Any hints and tips here. I think this is a really useful feature and I'd love to use it.

  1. Support Staff 1 Posted by bFlood on 15 Aug, 2016 08:14 PM

    bFlood's Avatar

    please try to export again and send this log:

    Main Arc2Earth Log File:
    C:\Users{{user}}\AppData\Local\Arc2Earth\DebugLog.log

  2. 2 Posted by Alistiar Brown on 15 Aug, 2016 08:32 PM

    Alistiar Brown's Avatar

    I had trouble attaching , but I pasted it into here :-

    8/15/2016 2:25:42 PM Starting Arc2Earth log...
    8/15/2016 2:25:42 PM Arc2Earth 3.1.5508.27078
    8/15/2016 2:25:42 PM A2EExtension.ctor
    8/15/2016 2:25:42 PM IE Version: 11.0.9600.18427
    8/15/2016 2:25:42 PM A2EExtension.ctor end
    8/15/2016 2:25:42 PM License.cctor
    8/15/2016 2:25:42 PM License.ctor
    8/15/2016 2:25:42 PM Begin CheckLicense
    8/15/2016 2:25:42 PM GetLicenseFromRegistry true
    8/15/2016 2:25:42 PM Begin License.Update
    8/15/2016 2:25:42 PM End License.Update
    8/15/2016 2:25:43 PM End CheckLicense
    8/15/2016 2:25:43 PM Begin License CreateLimits
    8/15/2016 2:25:43 PM End License CreateLimits
    8/15/2016 2:25:43 PM MapTileLayer.ctor
    8/15/2016 2:25:43 PM MapTileLayer.ctor end
    8/15/2016 2:25:43 PM SetWebProxy: Auto
    8/15/2016 2:25:43 PM DpiX: 96
    8/15/2016 2:25:43 PM DpiY: 96
    8/15/2016 2:25:46 PM System.NullReferenceException: Object reference not set to an instance of an object.
       at SDL.Client.Output.A2EConnect.SplitExtentFromMxd(String mxdFile, Int32 cutters, Boolean fullExtent)

  3. Support Staff 3 Posted by bFlood on 16 Aug, 2016 12:31 PM

    bFlood's Avatar

    is that the full debug log?

    can you try exporting with a single process (remove the "cutters" param) and see if it works? that should show us if its the MXD itself or something about the extent

    thanks

  4. 4 Posted by Alistiar Brown on 16 Aug, 2016 02:44 PM

    Alistiar Brown's Avatar

    Yes that was the full debug log. I deleted the log before starting the run, as otherwise it had a ton of stuff in that wasn't relevant.

    I ran it without the cutters param and it works - it's just a lot slower.

  5. Support Staff 5 Posted by bFlood on 16 Aug, 2016 02:46 PM

    bFlood's Avatar

    can you try it with 2 cutters and then 4 cutters

  6. 6 Posted by Alistiar Brown on 16 Aug, 2016 02:52 PM

    Alistiar Brown's Avatar

    So I tried with 2 and 4 cutters on a different MXD and it still failed

    Here is my debug.log

    8/16/2016 8:51:48 AM Starting Arc2Earth log...
    8/16/2016 8:51:48 AM Arc2Earth 3.1.5508.27078
    8/16/2016 8:51:48 AM A2EExtension.ctor
    8/16/2016 8:51:48 AM IE Version: 11.0.9600.18427
    8/16/2016 8:51:48 AM A2EExtension.ctor end
    8/16/2016 8:51:48 AM License.cctor
    8/16/2016 8:51:48 AM License.ctor
    8/16/2016 8:51:48 AM Begin CheckLicense
    8/16/2016 8:51:48 AM GetLicenseFromRegistry true
    8/16/2016 8:51:48 AM Begin License.Update
    8/16/2016 8:51:48 AM End License.Update
    8/16/2016 8:51:48 AM End CheckLicense
    8/16/2016 8:51:48 AM Begin License CreateLimits
    8/16/2016 8:51:48 AM End License CreateLimits
    8/16/2016 8:51:49 AM MapTileLayer.ctor
    8/16/2016 8:51:49 AM MapTileLayer.ctor end
    8/16/2016 8:51:49 AM SetWebProxy: Auto
    8/16/2016 8:51:49 AM DpiX: 96
    8/16/2016 8:51:49 AM DpiY: 96
    8/16/2016 8:51:51 AM System.NullReferenceException: Object reference not set to an instance of an object.
       at SDL.Client.Output.A2EConnect.SplitExtentFromMxd(String mxdFile, Int32 cutters, Boolean fullExtent)

  7. 7 Posted by Alistiar Brown on 17 Aug, 2016 02:32 PM

    Alistiar Brown's Avatar

    Any further information on this?

  8. Support Staff 8 Posted by bFlood on 17 Aug, 2016 02:42 PM

    bFlood's Avatar

    sorry Alistiar, we cannot reproduce the error here. I suspect it has something to do with your specific MXD but I can't be sure

    We are looking at one more potential issue but I don't think its releated.

    finally, while I don't think it will help much, you can also download the latest version from your account page

  9. 9 Posted by Alistair.Brown on 17 Aug, 2016 07:31 PM

    Alistair.Brown's Avatar

    Thanks,

    So we've tried this on multiple MXD's and none have worked.

    I was going to re-install the software, but it says the latest date was 2015 - so I think we're on the latest one...

    So my question is, is this calling an ESRI process to split up the bounding box, or is this internal to Arc2E. Reason why I'm asking is to find out whether it's worth re-installing ESRI.

    I think this is a really important feature of Arc2E , so I'm super keen on trying to get this to work, any further help would be gratefully received.

  10. 10 Posted by Alistair.Brown on 17 Aug, 2016 09:39 PM

    Alistair.Brown's Avatar

    So I'd like to try this on another machine to check to make sure it's a problem with out setup.

    In order to do this, can you send me a trial license for a week or so, to figure out what is going wrong.

  11. Support Staff 11 Posted by bFlood on 18 Aug, 2016 11:35 AM

    bFlood's Avatar

    feel free to use your existing serial number on another computer for testing

    also, you can send me a sample MXD/data that doesn't work and I'll try it here

  12. 12 Posted by Alistair Brown on 18 Aug, 2016 07:46 PM

    Alistair Brown's Avatar

    OK it looks like we figured this out . Phew ;-) Thanks for your help Brian.

    If you look at our original cmd line we were not specifying the -bbox parameter - There's 2 reasons for this. Firstly, when we generate the script using the front end it doesn't put this in and secondly , reading the documentataion here http://get.arc2earth.com/static/help/CommandLine.html

    it says it ignores the -bbox paramater

    Once we modified our script to include the -bbox paramater everything ran nicely.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac