Map server catastrophic failure

Ben's Avatar

Ben

09 May, 2014 01:50 PM

I just updated A2E and I can't use it at all. Firstly, I can't find the toolbar that is showing in your screenshots (see capture.jpg). Secondly when I try and access the basemaps through the gis server an error pops saying "catastrophic failure" (see capture2.jpg). Thirdly, there is no option to add google data by going to File>Add Data (see capture3.jpg).

  1. Support Staff 1 Posted by bFlood on 09 May, 2014 03:55 PM

    bFlood's Avatar

    hi ben

    did you have Admin rights when you installed the software? Both of these issues would occur if Arc2Earth was not fully installed

    cheers
    brian

  2. 2 Posted by Ben on 09 May, 2014 04:16 PM

    Ben's Avatar

    Yes I did.

  3. Support Staff 3 Posted by bFlood on 09 May, 2014 04:18 PM

    bFlood's Avatar

    can you run the installer again and send me the "Log" data on the window that appears at the end of the install (the Log data is on the second tab)

  4. 4 Posted by Ben on 09 May, 2014 04:20 PM

    Ben's Avatar

    Starting A2ELicense...
    Arc2Earth Install Folder: D:\Program Files (x86)\Arc2Earth LLC\Arc2Earth
    Arc2Earth Version: 3.1.5234.23301
    DotNet Version: 2.0.50727.5477
    IE Version: 11.0.9600.17105
    ArcGIS Version: 10.2.3348
    Windows Version: Microsoft Windows NT 6.1.7601 Service Pack 1
    Windows CPU: 64bit
    MachineName: BEN-PC
    CurrentUser: SYSTEM
    IsLocalAdmin: True
    Step 1 - RegisterDotNet
    Error - Could not locate RegAsm at D:\Windows\Microsoft.NET\Framework\v2.0.50727\regasm.exe
    Step 2 - RegisterWithArcGIS
    ESRIRegAsm exists: True C:\Program Files (x86)\Common Files\ArcGIS\bin\ESRIRegAsm.exe
    KMLExporter.ecfg exists: True D:\Program Files (x86)\Arc2Earth LLC\Arc2Earth\KMLExporter.ecfg
    Folder D:\Program Files (x86)\ArcGIS\Desktop10.3\bin\Configuration\CATID exists: False
    Folder D:\Program Files (x86)\ArcGIS\Desktop10.2\bin\Configuration\CATID exists: True
    Copying config file to D:\Program Files (x86)\ArcGIS\Desktop10.2\bin\Configuration\CATID\KMLExporter.ecfg
    Step 3 - CheckInternetConnection
    Checking SystemWebProxy...
    Test1 - WebClient connecting to http://www.google.com
    Test2.a - IE connecting to http://apps.arc2earth.com
    Test2.a - Success
    Test2.b - WebClient connecting to http://get.arc2earth.com
    Test2.b - Success
    Step 4 - Registering Data Services with http.sys
    Successfully added url: http://127.0.0.1:54323/ to http.sys via netsh
    Step 5 - ActivateLicense
    CheckLicense result: Community

  5. Support Staff 5 Posted by bFlood on 09 May, 2014 04:30 PM

    bFlood's Avatar

    hi ben

    ok, it looks like your program files are on a non-standard drive (D:). This should still work but I'll have take a look, I know we've had problems with this before. This is definitely the reason why the toolbars are not showing up

    cheers
    brian

  6. Support Staff 6 Posted by bFlood on 09 May, 2014 04:32 PM

    bFlood's Avatar

    can you open a cmd window and run:

    C:\Windows\Microsoft.NET\Framework\v2.0.50727\regasm.exe "D:\Program Files (x86)\Arc2Earth LLC\Arc2Earth\KMLExporter.dll"

  7. 7 Posted by Ben on 09 May, 2014 05:05 PM

    Ben's Avatar

    Ok, I did that, this is the output is attached.

  8. 8 Posted by Ben on 09 May, 2014 05:06 PM

    Ben's Avatar

    It got cutoff, it also said "Types registered successfully"

  9. Support Staff 9 Posted by bFlood on 09 May, 2014 05:07 PM

    bFlood's Avatar

    ok, can you open ArcMap now and see the toolbars?

  10. 10 Posted by Ben on 09 May, 2014 05:10 PM

    Ben's Avatar

    Nope, it's the same.

  11. 11 Posted by Ben on 09 May, 2014 05:12 PM

    Ben's Avatar

    I don't know what caused it, but now when I try and add a toolbar by using Customize>Toolbars, the Arc2Earth toolbars disappear from the menu when I click them.

  12. 12 Posted by Ben on 09 May, 2014 05:14 PM

    Ben's Avatar

    And I get this error now when I try to access imagery from catalog.

  13. 13 Posted by Ben on 09 May, 2014 05:24 PM

    Ben's Avatar

    It looks like A2EDS is no longer initializing? It's not showing up in my task bar like it was before.

  14. Support Staff 14 Posted by bFlood on 09 May, 2014 05:30 PM

    bFlood's Avatar

    Arc2Earth starts this exe when ArcMap starts, if its not running when ArcMap is running then something has occured on A2E's startup. Can you send me that log file as well (A2E toolbar->Help->Show Options-> Show log)

    thanks
    brian

  15. 15 Posted by Ben on 09 May, 2014 05:31 PM

    Ben's Avatar

    I can't access the A2E toolbar anymore.

    Starting A2ELicense...
    Arc2Earth Install Folder: D:\Program Files (x86)\Arc2Earth LLC\Arc2Earth
    Arc2Earth Version: 3.1.5234.23301
    DotNet Version: 2.0.50727.5477
    IE Version: 11.0.9600.17105
    ArcGIS Version: 10.2.3348
    Windows Version: Microsoft Windows NT 6.1.7601 Service Pack 1
    Windows CPU: 64bit
    MachineName: BEN-PC
    CurrentUser: Ben
    IsLocalAdmin: True
    Step 1 - RegisterDotNet
    Error - Could not locate RegAsm at D:\Windows\Microsoft.NET\Framework\v2.0.50727\regasm.exe
    Step 2 - RegisterWithArcGIS
    ESRIRegAsm exists: True C:\Program Files (x86)\Common Files\ArcGIS\bin\ESRIRegAsm.exe
    KMLExporter.ecfg exists: True D:\Program Files (x86)\Arc2Earth LLC\Arc2Earth\KMLExporter.ecfg
    Folder D:\Program Files (x86)\ArcGIS\Desktop10.3\bin\Configuration\CATID exists: False
    Folder D:\Program Files (x86)\ArcGIS\Desktop10.2\bin\Configuration\CATID exists: True
    Copying config file to D:\Program Files (x86)\ArcGIS\Desktop10.2\bin\Configuration\CATID\KMLExporter.ecfg
    Step 3 - CheckInternetConnection
    Checking SystemWebProxy...
    Test1 - WebClient connecting to http://www.google.com
    Test2.a - IE connecting to http://apps.arc2earth.com
    Test2.a - Success
    Test2.b - WebClient connecting to http://get.arc2earth.com
    Test2.b - Success
    Step 4 - Registering Data Services with http.sys
    Successfully added url: http://127.0.0.1:54323/ to http.sys via netsh
    Step 5 - ActivateLicense
    CheckLicense result: Community

  16. Support Staff 16 Posted by bFlood on 09 May, 2014 06:16 PM

    bFlood's Avatar

    hi ben

    ok, I guess there's more issues when ArcMap/Arc2Earth are not installed on C: drive, I'll have to take a closer look and get back to you

    brian

  17. 17 Posted by Ben on 09 May, 2014 06:27 PM

    Ben's Avatar

    Is there somewhere to download the previous version?

  18. Support Staff 18 Posted by bFlood on 09 May, 2014 06:33 PM

    bFlood's Avatar
  19. 19 Posted by Ben on 09 May, 2014 08:27 PM

    Ben's Avatar

    I can't even use the old version now. I completely uninstalled A2E and the map server and toolbar options are still showing up in the customize menu, but they don't work. I don't know what to do.

  20. 20 Posted by Steve Roberson on 10 May, 2014 05:47 PM

    Steve Roberson's Avatar

    I'm having this problem too. I installed on the C drive. I have uninstalled and reinstalled several times. Bing works fine, when I choose Google it crashes Arcmap. It shows the (degraded) next to google on my toolbar too.

  21. 21 Posted by Jeremy Soules on 10 May, 2014 06:07 PM

    Jeremy Soules's Avatar

    I, too, am having a problem similar in nature to that problem of which Mr. Ben and Mr. Steve are having currently as an experience. Reinstalled the old version, I did, and now that is working as it was prior to my uninstallation of this version which is the old one, and the installation of the haunted new version. Please advise.

  22. 22 Posted by Ben on 12 May, 2014 03:34 PM

    Ben's Avatar

    Just as an update, the A2E update on my C drive, and was able to access imagery through the GIS server connection in catalog. Interestingly, the license manager said that it was unable to register with Arc (I'm assuming because it's installed on my D drive). That is the only functionality I have, however. I am still unable to open any toolbars or access any other functions.

  23. 23 Posted by Steve Roberson on 14 May, 2014 02:42 PM

    Steve Roberson's Avatar

    Any progress being made on this issue? I really need google imagery asap.

  24. Support Staff 24 Posted by bFlood on 14 May, 2014 02:46 PM

    bFlood's Avatar

    does "C:\Windows\Microsoft.NET\Framework\v2.0.50727\regasm.exe" exist on your computer?

  25. 25 Posted by Steve Roberson on 14 May, 2014 03:09 PM

    Steve Roberson's Avatar

    yes, it is regasm.exe.config

  26. Support Staff 26 Posted by bFlood on 14 May, 2014 03:13 PM

    bFlood's Avatar

    can you try this installer?
    https://s3.amazonaws.com/a2e_installer/Arc2EarthSetup.msi

    thanks
    brian

  27. 27 Posted by Steve Roberson on 14 May, 2014 03:54 PM

    Steve Roberson's Avatar

    same results using the new installer.

  28. Support Staff 28 Posted by bFlood on 14 May, 2014 03:58 PM

    bFlood's Avatar

    i need to see the installer logs

  29. Support Staff 29 Posted by bFlood on 14 May, 2014 09:03 PM

    bFlood's Avatar

    ok, this issue has been solved on several other computers using the new installer here:
    https://s3.amazonaws.com/a2e_installer/Arc2EarthSetup.msi

    (steve - this is a different version then the one you tried)

  30. 30 Posted by Ben on 16 May, 2014 01:01 PM

    Ben's Avatar

    Can anyone confirm this works?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • Capture.JPG 16.7 KB
  • Capture2.JPG 38.9 KB
  • Capture3.JPG 36.8 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac